C++20 Modules compiler support

The particular GCC G++ version need to be compiled with the necessary C++20 module support enabled. The typical GCC locations (apt get, MinGW) currently don’t have C++20 modules enabled. Currently CMake 3.17 is also not ready for C++20 modules yes.

An example of a GCC-supported C++20 modules example is available.